Splunk observability cloud front and backend are facing slowness

Incident Report for Splunk Observability Cloud EU0

Resolved

Systems have recovered and are currently stable. This incident has been resolved.
Posted Oct 04, 2025 - 06:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Oct 04, 2025 - 05:39 UTC

Update

We are currently experiencing widespread slowness, dropping metrics and spans across the EU-0 realm and are actively investigating the issue
Posted Oct 04, 2025 - 05:05 UTC

Update

We are continuing to investigate this issue.
Posted Oct 04, 2025 - 05:01 UTC

Update

We are continuing to investigate this issue.
Posted Oct 04, 2025 - 04:25 UTC

Investigating

The Splunk observability web UI and the backend services are slowing down. We might also be dropping metrics and spans. We are investigating
Posted Oct 04, 2025 - 04:03 UTC
This incident affected: Splunk Observability Cloud Web Interface and Splunk Observability Cloud API.