Splunk Observability Cloud Web Interface is slow

Incident Report for Splunk Observability Cloud EU0

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 16:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2025 - 16:16 UTC

Investigating

We are investigating a slowness of the Splunk Observability Cloud web application. Data ingest is not impacted at this time. We will provide an update as soon as possible.
Posted Oct 03, 2025 - 15:16 UTC
This incident affected: Splunk Observability Cloud Web Interface.